Arbitrary Argument Injection Affecting ansible-core package, versions <2.18.3-150400.9.17.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.27% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-ANSIBLECORE-19853724
  • published16 Sept 2026
  • disclosed14 Sept 2026

Introduced: 14 Sep 2026

CVE-2026-16493  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 ansible-core to version 2.18.3-150400.9.17.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ansible-core package and not the ansible-core package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A flaw was found in ansible-core. The _extract_collection_from_git() function in ansible-core's concrete_artifact_manager.py constructs git clone commands without a '--' (end-of-options) separator before user-supplied URLs when installing collections from git sources. An attacker who provides a crafted collection source URI containing git argument injection payloads can achieve arbitrary command execution when a user runs 'ansible-galaxy collection install' with the malicious source. This is an incomplete fix for CVE-2026-11332, which hardened the role install path but missed the equivalent collection install code path.

CVSS Base Scores

version 3.1