Improper Verification of Cryptographic Signature Affecting aws-cli package, versions <1.33.26-150400.34.7.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.5% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-AWSCLI-13706661
  • published24 Oct 2025
  • disclosed23 Oct 2025

Introduced: 23 Oct 2025

CVE-2024-48949  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 aws-cli to version 1.33.26-150400.34.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aws-cli package and not the aws-cli package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

The verify function in lib/elliptic/eddsa/index.js in the Elliptic package before 6.5.6 for Node.js omits "sig.S().gte(sig.eddsa.curve.n) || sig.S().isNeg()" validation.

CVSS Base Scores

version 3.1