CVE-2026-78669 Affecting aws-iam-authenticator package, versions <0.7.22-150000.1.23.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.61% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-AWSIAMAUTHENTICATOR-21691892
  • published24 Oct 2026
  • disclosed23 Oct 2026

Introduced: 23 Oct 2026

NewCVE-2026-78669  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 aws-iam-authenticator to version 0.7.22-150000.1.23.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aws-iam-authenticator package and not the aws-iam-authenticator package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A malicious HTTP/2 peer can cause excessive CPU consumption in the client or server by opening a large number of streams and then sending many small SETTINGS frames containing SETTINGS_INITIAL_WINDOW_SIZE values.

CVSS Base Scores

version 3.1