Insufficient Verification of Data Authenticity Affecting booth package, versions <1.1+git0.09b0074-150600.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.53% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-BOOTH-7267307
  • published18 Jun 2024
  • disclosed17 Jun 2024

Introduced: 17 Jun 2024

CVE-2024-3049  (opens in a new tab)
CWE-345  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 booth to version 1.1+git0.09b0074-150600.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream booth package and not the booth package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A flaw was found in Booth, a cluster ticket manager. If a specially-crafted hash is passed to gcry_md_get_algo_dlen(), it may allow an invalid HMAC to be accepted by the Booth server.

CVSS Base Scores

version 3.1