CVE-2026-41051 Affecting csync2 package, versions <2.0+git.1600444747.83b3644-150300.3.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.08% (1st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-CSYNC2-17101674
  • published30 May 2026
  • disclosed29 May 2026

Introduced: 29 May 2026

CVE-2026-41051  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 csync2 to version 2.0+git.1600444747.83b3644-150300.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream csync2 package and not the csync2 package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

csync2 uses insecure temporary directories when compiled with C99 or later, allowing for TOCTOU style attacks on the temporary directories.

CVSS Base Scores

version 3.1