CVE-2024-36472 Affecting gnome-extensions package, versions <45.3-150600.5.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.34% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-GNOMEEXTENSIONS-7548519
  • published23 Jul 2024
  • disclosed22 Jul 2024

Introduced: 22 Jul 2024

CVE-2024-36472  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 gnome-extensions to version 45.3-150600.5.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-extensions package and not the gnome-extensions package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

In GNOME Shell through 45.7, a portal helper can be launched automatically (without user confirmation) based on network responses provided by an adversary (e.g., an adversary who controls the local Wi-Fi network), and subsequently loads untrusted JavaScript code, which may lead to resource consumption or other impacts depending on the JavaScript code's behavior.

CVSS Base Scores

version 3.1