CVE-2025-11230 Affecting haproxy package, versions <2.8.11+git0.01c1056a4-150600.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.74% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-HAPROXY-13543001
  • published14 Oct 2025
  • disclosed13 Oct 2025

Introduced: 13 Oct 2025

CVE-2025-11230  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 haproxy to version 2.8.11+git0.01c1056a4-150600.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haproxy package and not the haproxy package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

Inefficient algorithm complexity in mjson in HAProxy allows remote attackers to cause a denial of service via specially crafted JSON requests.

CVSS Base Scores

version 3.1