In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.
Test your applicationsUpgrade SLES:15.6 hdf5_1_10_11-gnu-openmpi4-hpc-module to version 1.10.11-150400.3.17.2 or higher.
Note: Versions mentioned in the description apply only to the upstream hdf5_1_10_11-gnu-openmpi4-hpc-module package and not the hdf5_1_10_11-gnu-openmpi4-hpc-module package as distributed by SLES.
See How to fix? for SLES:15.6 relevant fixed versions and status.
HDF5 through 1.14.3 contains a stack buffer overflow in H5FL_arr_malloc, resulting in the corruption of the instruction pointer and causing denial of service or potential code execution.