Integer Overflow or Wraparound Affecting hplip-hpijs package, versions <3.26.4-150600.4.9.1


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.81% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-HPLIPHPIJS-17135866
  • published3 Jun 2026
  • disclosed2 Jun 2026

Introduced: 2 Jun 2026

CVE-2026-8631  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 hplip-hpijs to version 3.26.4-150600.4.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hplip-hpijs package and not the hplip-hpijs package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A potential security vulnerability has been identified in the HP Linux Imaging and Printing Software. This potential vulnerability may allow escalation of privileges and/or arbitrary code execution via an integer overflow in the hpcups processing path when handling crafted print data.

CVSS Base Scores

version 3.1