Uncontrolled Recursion Affecting jq package, versions <1.7.1-150000.3.25.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.16% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-JQ-20044066
  • published22 Sept 2026
  • disclosed21 Sept 2026

Introduced: 21 Sep 2026

CVE-2026-40612  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 jq to version 1.7.1-150000.3.25.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jq package and not the jq package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

jq is a command-line JSON processor. In 1.8.1 and earlier, jv_contains recurses into nested arrays/objects with no depth limit. With a sufficiently nested input structure (built programmatically with reduce, since the JSON parser caps at depth 10000), the C stack is exhausted.

CVSS Base Scores

version 3.1