CVE-2024-45338 Affecting kubevirt-manifests package, versions <1.4.1-150600.5.24.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.07% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-KUBEVIRTMANIFESTS-12983511
  • published20 Sept 2025
  • disclosed19 Sept 2025

Introduced: 19 Sep 2025

CVE-2024-45338  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 kubevirt-manifests to version 1.4.1-150600.5.24.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kubevirt-manifests package and not the kubevirt-manifests package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

An attacker can craft an input to the Parse functions that would be processed non-linearly with respect to its length, resulting in extremely slow parsing. This could cause a denial of service.

CVSS Base Scores

version 3.1