CVE-2024-32487 Affecting less package, versions <643-150600.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.63% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LESS-7268551
  • published19 Jun 2024
  • disclosed18 Jun 2024

Introduced: 18 Jun 2024

CVE-2024-32487  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 less to version 643-150600.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream less package and not the less package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

less through 653 allows OS command execution via a newline character in the name of a file, because quoting is mishandled in filename.c. Exploitation typically requires use with attacker-controlled file names, such as the files extracted from an untrusted archive. Exploitation also requires the LESSOPEN environment variable, but this is set by default in many common cases.

CVSS Base Scores

version 3.1