CVE-2016-9840 Affecting libboost_iostreams1_66_0-devel package, versions <1.66.0-150200.12.7.1


Severity

Recommended
critical

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.88% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBBOOSTIOSTREAMS1660DEVEL-11174239
  • published29 Jul 2025
  • disclosed31 Jul 2025

Introduced: 29 Jul 2025

CVE-2016-9840  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libboost_iostreams1_66_0-devel to version 1.66.0-150200.12.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libboost_iostreams1_66_0-devel package and not the libboost_iostreams1_66_0-devel package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

inftrees.c in zlib 1.2.8 might allow context-dependent attackers to have unspecified impact by leveraging improper pointer arithmetic.

References

CVSS Base Scores

version 3.1