Integer Overflow or Wraparound Affecting libgepub-devel package, versions <0.7.1-150600.3.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBGEPUBDEVEL-10629052
  • published5 Jul 2025
  • disclosed4 Jul 2025

Introduced: 4 Jul 2025

CVE-2025-6196  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libgepub-devel to version 0.7.1-150600.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgepub-devel package and not the libgepub-devel package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A flaw was found in libgepub, a library used to read EPUB files. The software mishandles file size calculations when opening specially crafted EPUB files, leading to incorrect memory allocations. This issue causes the application to crash. Known affected usage includes desktop services like Tumbler, which may process malicious files automatically when browsing directories. While no direct remote attack vectors are confirmed, any application using libgepub to parse user-supplied EPUB content could be vulnerable to a denial of service.

CVSS Base Scores

version 3.1