Reachable Assertion Affecting libjasper-devel package, versions <4.2.8-150600.4.5.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.23% (14th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBJASPERDEVEL-13843223
  • published6 Nov 2025
  • disclosed5 Nov 2025

Introduced: 5 Nov 2025

CVE-2025-8836  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libjasper-devel to version 4.2.8-150600.4.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjasper-devel package and not the libjasper-devel package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A vulnerability was determined in JasPer up to 4.2.5. Affected by this issue is the function jpc_floorlog2 of the file src/libjasper/jpc/jpc_enc.c of the component JPEG2000 Encoder. The manipulation leads to reachable assertion. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. The patch is identified as 79185d32d7a444abae441935b20ae4676b3513d4. It is recommended to apply a patch to fix this issue.

CVSS Base Scores

version 3.1