CVE-2024-32620 Affecting libopenmpi_4_1_6-gnu-hpc package, versions <4.1.6-150600.3.2.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBOPENMPI416GNUHPC-7382205
  • published26 Jun 2024
  • disclosed25 Jun 2024

Introduced: 25 Jun 2024

CVE-2024-32620  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libopenmpi_4_1_6-gnu-hpc to version 4.1.6-150600.3.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libopenmpi_4_1_6-gnu-hpc package and not the libopenmpi_4_1_6-gnu-hpc package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

HDF5 Library through 1.14.3 contains a heap-based buffer over-read in H5F_addr_decode_len in H5Fint.c, resulting in the corruption of the instruction pointer.

CVSS Base Scores

version 3.1