Out-of-bounds Write Affecting libopenmpi4-gnu-hpc package, versions <4.1.6-150600.3.2.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.67% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBOPENMPI4GNUHPC-7378173
  • published26 Jun 2024
  • disclosed25 Jun 2024

Introduced: 25 Jun 2024

CVE-2024-32608  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libopenmpi4-gnu-hpc to version 4.1.6-150600.3.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libopenmpi4-gnu-hpc package and not the libopenmpi4-gnu-hpc package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

HDF5 library through 1.14.3 has memory corruption in H5A__close resulting in the corruption of the instruction pointer and causing denial of service or potential code execution.

CVSS Base Scores

version 3.1