CVE-2026-31911 Affecting libpcap1 package, versions <1.10.4-150600.3.12.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.11% (1st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBPCAP1-19853176
  • published16 Sept 2026
  • disclosed15 Sept 2026

Introduced: 15 Sep 2026

CVE-2026-31911  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libpcap1 to version 1.10.4-150600.3.12.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap1 package and not the libpcap1 package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

libpcap BPF interpreter calls abort() if it encounters a BPF instruction that has an invalid opcode. In particular uncommon use cases a crafted filter program can terminate the OS process.

CVSS Base Scores

version 3.1