CVE-2025-43903 Affecting libpoppler-qt6-devel package, versions <24.03.0-150600.3.13.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBPOPPLERQT6DEVEL-10004965
  • published3 May 2025
  • disclosed2 May 2025

Introduced: 2 May 2025

CVE-2025-43903  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libpoppler-qt6-devel to version 24.03.0-150600.3.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpoppler-qt6-devel package and not the libpoppler-qt6-devel package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

NSSCryptoSignBackend.cc in Poppler before 25.04.0 does not verify the adbe.pkcs7.sha1 signatures on documents, resulting in potential signature forgeries.

CVSS Base Scores

version 3.1