CVE-2025-52194 Affecting libsndfile1 package, versions <1.0.28-150000.5.23.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.65% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBSNDFILE1-16755544
  • published19 May 2026
  • disclosed18 May 2026

Introduced: 18 May 2026

CVE-2025-52194  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libsndfile1 to version 1.0.28-150000.5.23.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsndfile1 package and not the libsndfile1 package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A buffer overflow vulnerability exists in libsndfile version 1.2.2 and potentially earlier versions when processing malformed IRCAM audio files. The vulnerability occurs in the ircam_read_header function at src/ircam.c:164 during sample rate processing, leading to memory corruption and potential code execution.

CVSS Base Scores

version 3.1