CVE-2024-39134 Affecting libzzip-0-13 package, versions <0.13.72-150600.4.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.6% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-LIBZZIP013-7689090
  • published16 Aug 2024
  • disclosed15 Aug 2024

Introduced: 15 Aug 2024

CVE-2024-39134  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 libzzip-0-13 to version 0.13.72-150600.4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libzzip-0-13 package and not the libzzip-0-13 package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A Stack Buffer Overflow vulnerability in zziplibv 0.13.77 allows attackers to cause a denial of service via the __zzip_fetch_disk_trailer() function at /zzip/zip.c.

CVSS Base Scores

version 3.1