CVE-2024-4367 Affecting MozillaFirefox package, versions <115.11.0-150200.152.137.2


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
70.66% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-MOZILLAFIREFOX-7086323
  • published24 May 2024
  • disclosed23 May 2024

Introduced: 23 May 2024

CVE-2024-4367  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 MozillaFirefox to version 115.11.0-150200.152.137.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox package and not the MozillaFirefox package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A type check was missing when handling fonts in PDF.js, which would allow arbitrary JavaScript execution in the PDF.js context. This vulnerability affects Firefox < 126, Firefox ESR < 115.11, and Thunderbird < 115.11.

CVSS Base Scores

version 3.1