CVE-2024-4769 Affecting MozillaFirefox-translations-common package, versions <115.11.0-150200.152.137.2


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.37% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-MOZILLAFIREFOXTRANSLATIONSCOMMON-7086395
  • published24 May 2024
  • disclosed23 May 2024

Introduced: 23 May 2024

CVE-2024-4769  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 MozillaFirefox-translations-common to version 115.11.0-150200.152.137.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-translations-common package and not the MozillaFirefox-translations-common package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

When importing resources using Web Workers, error messages would distinguish the difference between application/javascript responses and non-script responses. This could have been abused to learn information cross-origin. This vulnerability affects Firefox < 126, Firefox ESR < 115.11, and Thunderbird < 115.11.

CVSS Base Scores

version 3.1