Out-of-bounds Read Affecting openmpi_4_1_6-gnu-hpc package, versions <4.1.6-150600.3.2.1


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.15% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-OPENMPI416GNUHPC-7372361
  • published26 Jun 2024
  • disclosed25 Jun 2024

Introduced: 25 Jun 2024

CVE-2017-17507  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 openmpi_4_1_6-gnu-hpc to version 4.1.6-150600.3.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openmpi_4_1_6-gnu-hpc package and not the openmpi_4_1_6-gnu-hpc package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

In HDF5 1.10.1, there is an out of bounds read vulnerability in the function H5T_conv_struct_opt in H5Tconv.c in libhdf5.a. For example, h5dump would crash when someone opens a crafted hdf5 file.