CVE-2026-3172 Affecting postgresql16-pgvector package, versions <0.8.2-150600.13.9.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-POSTGRESQL16PGVECTOR-15852452
  • published31 Mar 2026
  • disclosed26 Mar 2026

Introduced: 26 Mar 2026

CVE-2026-3172  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 postgresql16-pgvector to version 0.8.2-150600.13.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql16-pgvector package and not the postgresql16-pgvector package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

Buffer overflow in parallel HNSW index build in pgvector 0.6.0 through 0.8.1 allows a database user to leak sensitive data from other relations or crash the database server.

CVSS Base Scores

version 3.1