Improper Verification of Cryptographic Signature Affecting python311-Authlib package, versions <1.3.1-150600.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-PYTHON311AUTHLIB-7268520
  • published19 Jun 2024
  • disclosed18 Jun 2024

Introduced: 18 Jun 2024

CVE-2024-37568  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 python311-Authlib to version 1.3.1-150600.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-Authlib package and not the python311-Authlib package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

lepture Authlib before 1.3.1 has algorithm confusion with asymmetric public keys. Unless an algorithm is specified in a jwt.decode call, HMAC verification is allowed with any asymmetric public key. (This is similar to CVE-2022-29217 and CVE-2024-33663.)

CVSS Base Scores

version 3.1