CVE-2025-32873 Affecting python311-Django package, versions <4.2.11-150600.3.21.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
14.31% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-PYTHON311DJANGO-10110124
  • published10 May 2025
  • disclosed9 May 2025

Introduced: 9 May 2025

CVE-2025-32873  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 python311-Django to version 4.2.11-150600.3.21.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-Django package and not the python311-Django package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

An issue was discovered in Django 4.2 before 4.2.21, 5.1 before 5.1.9, and 5.2 before 5.2.1. The django.utils.html.strip_tags() function is vulnerable to a potential denial-of-service (slow performance) when processing inputs containing large sequences of incomplete HTML tags. The template filter striptags is also vulnerable, because it is built on top of strip_tags().

CVSS Base Scores

version 3.1