Arbitrary Argument Injection Affecting python311-GitPython package, versions <3.1.34.1693646983.2a2ae77-150400.9.11.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.41% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-PYTHON311GITPYTHON-19853195
  • published16 Sept 2026
  • disclosed15 Sept 2026

Introduced: 15 Sep 2026

CVE-2026-87818  (opens in a new tab)
CWE-88  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 python311-GitPython to version 3.1.34.1693646983.2a2ae77-150400.9.11.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-GitPython package and not the python311-GitPython package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

GitPython 3.1.59 fails to restrict the --no-index option in the high-level diff API, allowing attackers to read arbitrary filesystem paths as repository operands. Attackers can combine --no-index with -I/--ignore-matching-lines to create a content-dependent Boolean oracle, repeatedly querying local files to recover single-line secrets through distinguishable success or error responses.

CVSS Base Scores

version 3.1