CVE-2024-6174 Affecting python311-jsonpointer package, versions <2.3-150400.11.5.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.26% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-PYTHON311JSONPOINTER-16755555
  • published19 May 2026
  • disclosed18 May 2026

Introduced: 18 May 2026

CVE-2024-6174  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 python311-jsonpointer to version 2.3-150400.11.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-jsonpointer package and not the python311-jsonpointer package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

When a non-x86 platform is detected, cloud-init grants root access to a hardcoded url with a local IP address. To prevent this, cloud-init default configurations disable platform enumeration.

CVSS Base Scores

version 3.1