CVE-2024-3772 Affecting python311-pydantic package, versions <1.10.8-150400.9.10.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.96% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-PYTHON311PYDANTIC-8683014
  • published1 Feb 2025
  • disclosed31 Jan 2025

Introduced: 31 Jan 2025

CVE-2024-3772  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 python311-pydantic to version 1.10.8-150400.9.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-pydantic package and not the python311-pydantic package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

Regular expression denial of service in Pydanic < 2.4.0, < 1.10.13 allows remote attackers to cause denial of service via a crafted email string.

CVSS Base Scores

version 3.1