Out-of-bounds Read Affecting python3-Pillow package, versions <7.2.0-150300.3.15.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.24% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-PYTHON3PILLOW-7252942
  • published14 Jun 2024
  • disclosed13 Jun 2024

Introduced: 13 Jun 2024

CVE-2021-23437  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 python3-Pillow to version 7.2.0-150300.3.15.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-Pillow package and not the python3-Pillow package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.

CVSS Base Scores

version 3.1