CVE-2022-45198 Affecting python3-Pillow package, versions <7.2.0-150300.3.18.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.3% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-PYTHON3PILLOW-7687472
  • published15 Aug 2024
  • disclosed14 Aug 2024

Introduced: 14 Aug 2024

CVE-2022-45198  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 python3-Pillow to version 7.2.0-150300.3.18.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-Pillow package and not the python3-Pillow package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

Pillow before 9.2.0 performs Improper Handling of Highly Compressed GIF Data (Data Amplification).

CVSS Base Scores

version 3.1