Insecure Storage of Sensitive Information Affecting python3-scikit-learn package, versions <0.23.2-150300.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-PYTHON3SCIKITLEARN-7252163
  • published14 Jun 2024
  • disclosed13 Jun 2024

Introduced: 13 Jun 2024

CVE-2024-5206  (opens in a new tab)
CWE-922  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 python3-scikit-learn to version 0.23.2-150300.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-scikit-learn package and not the python3-scikit-learn package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A sensitive data leakage vulnerability was identified in scikit-learn's TfidfVectorizer, specifically in versions up to and including 1.4.1.post1, which was fixed in version 1.5.0. The vulnerability arises from the unexpected storage of all tokens present in the training data within the stop_words_ attribute, rather than only storing the subset of tokens required for the TF-IDF technique to function. This behavior leads to the potential leakage of sensitive information, as the stop_words_ attribute could contain tokens that were meant to be discarded and not stored, such as passwords or keys. The impact of this vulnerability varies based on the nature of the data being processed by the vectorizer.

CVSS Base Scores

version 3.1