Symlink Following Affecting squashfuse-tools package, versions <0.5.0-150600.3.2.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.23% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-SQUASHFUSETOOLS-15270220
  • published12 Feb 2026
  • disclosed11 Feb 2026

Introduced: 11 Feb 2026

CVE-2025-65105  (opens in a new tab)
CWE-61  (opens in a new tab)
CWE-706  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 squashfuse-tools to version 0.5.0-150600.3.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream squashfuse-tools package and not the squashfuse-tools package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.

CVSS Base Scores

version 3.1