CVE-2025-31163 Affecting transfig package, versions <3.2.9a-150600.3.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.2% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-TRANSFIG-10335934
  • published10 Jun 2025
  • disclosed9 Jun 2025

Introduced: 9 Jun 2025

CVE-2025-31163  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 transfig to version 3.2.9a-150600.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream transfig package and not the transfig package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

Segmentation fault in fig2dev in version 3.2.9a allows an attacker to availability via local input manipulation via put_patternarc function.

CVSS Base Scores

version 3.1