Buffer Overflow Affecting transfig package, versions <3.2.9a-150600.3.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-TRANSFIG-10335952
  • published10 Jun 2025
  • disclosed9 Jun 2025

Introduced: 9 Jun 2025

CVE-2025-46397  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 transfig to version 3.2.9a-150600.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream transfig package and not the transfig package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

A flaw was found in xfig. This vulnerability allows possible code execution via local input manipulation via bezier_spline function.

CVSS Base Scores

version 3.1