CVE-2025-50420 Affecting typelib-1_0-Poppler-0_18 package, versions <24.03.0-150600.3.19.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.35% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-TYPELIB10POPPLER018-11799853
  • published14 Aug 2025
  • disclosed13 Aug 2025

Introduced: 13 Aug 2025

CVE-2025-50420  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 typelib-1_0-Poppler-0_18 to version 24.03.0-150600.3.19.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-Poppler-0_18 package and not the typelib-1_0-Poppler-0_18 package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

An issue in the pdfseparate utility of freedesktop poppler v25.04.0 allows attackers to cause an infinite recursion via supplying a crafted PDF file. This can lead to a Denial of Service (DoS).

CVSS Base Scores

version 3.1