Improper Input Validation Affecting typelib-1_0-WebKit-6_0 package, versions <2.54.1-150600.12.81.4


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.51% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-TYPELIB10WEBKIT60-21470099
  • published23 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-17671  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 typelib-1_0-WebKit-6_0 to version 2.54.1-150600.12.81.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-WebKit-6_0 package and not the typelib-1_0-WebKit-6_0 package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

Insufficient validation of untrusted input in ANGLE in Google Chrome prior to 151.0.7922.72 allowed a remote attacker who had compromised the renderer process to potentially perform a sandbox escape via a crafted HTML page. (Chromium security severity: High)

CVSS Base Scores

version 3.1