Access of Resource Using Incompatible Type ('Type Confusion') Affecting webkitgtk-6_0-injected-bundles package, versions <2.54.1-150600.12.81.4


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.56% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES156-WEBKITGTK60INJECTEDBUNDLES-21470623
  • published23 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-17687  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade SLES:15.6 webkitgtk-6_0-injected-bundles to version 2.54.1-150600.12.81.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream webkitgtk-6_0-injected-bundles package and not the webkitgtk-6_0-injected-bundles package as distributed by SLES. See How to fix? for SLES:15.6 relevant fixed versions and status.

Type Confusion in ANGLE in Google Chrome prior to 151.0.7922.72 allowed a remote attacker who had compromised the renderer process to potentially perform a sandbox escape via a crafted HTML page. (Chromium security severity: High)

CVSS Base Scores

version 3.1