CVE-2024-21538 Affecting aws-cli package, versions <1.33.26-150400.34.7.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.87% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-AWSCLI-13706495
  • published24 Oct 2025
  • disclosed23 Oct 2025

Introduced: 23 Oct 2025

CVE-2024-21538  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 aws-cli to version 1.33.26-150400.34.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aws-cli package and not the aws-cli package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

Versions of the package cross-spawn before 6.0.6, from 7.0.0 and before 7.0.5 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by crafting a very large and well crafted string.

CVSS Base Scores

version 3.1