Use After Free Affecting busybox-static package, versions <1.37.0-150700.18.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.43% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-BUSYBOXSTATIC-12657355
  • published13 Sept 2025
  • disclosed12 Sept 2025

Introduced: 12 Sep 2025

CVE-2023-42364  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 busybox-static to version 1.37.0-150700.18.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream busybox-static package and not the busybox-static package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A use-after-free vulnerability in BusyBox v.1.36.1 allows attackers to cause a denial of service via a crafted awk pattern in the awk.c evaluate function.

CVSS Base Scores

version 3.1