CVE-2026-24030 Affecting dnsdist package, versions <1.9.12-150700.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.54% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-DNSDIST-16264507
  • published25 Apr 2026
  • disclosed24 Apr 2026

Introduced: 24 Apr 2026

CVE-2026-24030  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 dnsdist to version 1.9.12-150700.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dnsdist package and not the dnsdist package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

An attacker might be able to trick DNSdist into allocating too much memory while processing DNS over QUIC or DNS over HTTP/3 payloads, resulting in a denial of service. In setups with a large quantity of memory available this usually results in an exception and the QUIC connection is properly closed, but in some cases the system might enter an out-of-memory state instead and terminate the process.

CVSS Base Scores

version 3.1