CVE-2026-27854 Affecting dnsdist package, versions <1.9.12-150700.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.47% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-DNSDIST-16264529
  • published25 Apr 2026
  • disclosed24 Apr 2026

Introduced: 24 Apr 2026

CVE-2026-27854  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 dnsdist to version 1.9.12-150700.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dnsdist package and not the dnsdist package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

An attacker might be able to trigger a use-after-free by sending crafted DNS queries to a DNSdist using the DNSQuestion:getEDNSOptions method in custom Lua code. In some cases DNSQuestion:getEDNSOptions might refer to a version of the DNS packet that has been modified, thus triggering a use-after-free and potentially a crash resulting in denial of service.

CVSS Base Scores

version 3.1