CVE-2025-6297 Affecting dpkg-devel package, versions <1.19.0.4-150000.4.7.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.48% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-DPKGDEVEL-11559244
  • published9 Aug 2025
  • disclosed8 Aug 2025

Introduced: 8 Aug 2025

CVE-2025-6297  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 dpkg-devel to version 1.19.0.4-150000.4.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dpkg-devel package and not the dpkg-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

It was discovered that dpkg-deb does not properly sanitize directory permissions when extracting a control member into a temporary directory, which is documented as being a safe operation even on untrusted data. This may result in leaving temporary files behind on cleanup. Given automated and repeated execution of dpkg-deb commands on adversarial .deb packages or with well compressible files, placed inside a directory with permissions not allowing removal by a non-root user, this can end up in a DoS scenario due to causing disk quota exhaustion or disk full conditions.

CVSS Base Scores

version 3.1