OS Command Injection Affecting dracut-mkinitrd-deprecated package, versions <059+suse.576.g72b98359a-150700.3.23.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.22% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-DRACUTMKINITRDDEPRECATED-19680567
  • published11 Sept 2026
  • disclosed3 Sept 2026

Introduced: 3 Sep 2026

CVE-2026-16445  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 dracut-mkinitrd-deprecated to version 059+suse.576.g72b98359a-150700.3.23.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dracut-mkinitrd-deprecated package and not the dracut-mkinitrd-deprecated package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in dracut. A remote attacker on the adjacent network can exploit this vulnerability by providing specially crafted DHCP options, such as a malicious root-path, next-server, or bootfile name, to a system using dracut's NetworkManager-based initrd network module. These options are improperly handled and written into a temporary shell script without proper escaping, leading to command injection. This allows the attacker to achieve root code execution within the initramfs during system boot.

CVSS Base Scores

version 3.1