Incomplete Blacklist Affecting emacs-x11 package, versions <27.2-150400.3.37.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.65% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-EMACSX11-21691866
  • published24 Oct 2026
  • disclosed23 Oct 2026

Introduced: 23 Oct 2026

NewCVE-2026-108976  (opens in a new tab)
CWE-184  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 emacs-x11 to version 27.2-150400.3.37.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream emacs-x11 package and not the emacs-x11 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

GNU Emacs before 31.2 (and TRAMP through 2.8.2) allows OS command injection via a filename because tramp-user-regexp has an incomplete list of disallowed inputs. NOTE: this issue exists because of an incomplete fix for CVE-2026-79992.

CVSS Base Scores

version 3.1