CVE-2026-2604 Affecting evolution-data-server-devel package, versions <3.50.3-150600.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.28% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-EVOLUTIONDATASERVERDEVEL-15371646
  • published4 Mar 2026
  • disclosed3 Mar 2026

Introduced: 3 Mar 2026

CVE-2026-2604  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 evolution-data-server-devel to version 3.50.3-150600.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream evolution-data-server-devel package and not the evolution-data-server-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in evolution-data-server. Inconsistent comparison logic in the addressbook file backend allows a Flatpak application with D-Bus access to craft a malicious URI containing directory traversal sequences. This URI is stored without proper validation during contact creation or modification. Later, during contact deletion, the URI is processed with a less strict check, leading to the deletion of arbitrary files on the host filesystem. This could potentially include critical Flatpak override files.

CVSS Base Scores

version 3.1