Out-of-bounds Read Affecting gimp-lang package, versions <2.10.30-150400.3.85.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-GIMPLANG-21691846
  • published24 Oct 2026
  • disclosed23 Oct 2026

Introduced: 23 Oct 2026

NewCVE-2026-82328  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 gimp-lang to version 2.10.30-150400.3.85.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gimp-lang package and not the gimp-lang package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in the file-ico plugin in GIMP. When processing a specially crafted ICO image file, the plugin does not properly validate the used_clrs (palette count) parameter. This incorrect validation leads to improper memory bounds checking, resulting in a heap out-of-bounds read. This issue can result in an application crash, leading to a denial of service or a limited information disclosure of heap memory contents.

CVSS Base Scores

version 3.1