Out-of-Bounds Affecting gimp-plugin-aa package, versions <2.10.30-150400.3.85.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-GIMPPLUGINAA-21691823
  • published24 Oct 2026
  • disclosed23 Oct 2026

Introduced: 23 Oct 2026

NewCVE-2026-106063  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 gimp-plugin-aa to version 2.10.30-150400.3.85.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gimp-plugin-aa package and not the gimp-plugin-aa package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A heap-based buffer overflow was found in GIMP’s DICOM export plug-in. When exporting an image with extremely large width and height, the export path allocates a buffer using a 32-bit width * height (and bytes-per-pixel) product that can overflow. GEGL then writes the full uncompressed extent into the undersized buffer, after integer overflow in the allocation size

CVSS Base Scores

version 3.1