Out-of-bounds Read Affecting gnome-extensions package, versions <45.3-150700.11.6.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.13% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-GNOMEEXTENSIONS-20251432
  • published29 Sept 2026
  • disclosed28 Sept 2026

Introduced: 28 Sep 2026

CVE-2026-91786  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 gnome-extensions to version 45.3-150700.11.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-extensions package and not the gnome-extensions package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in GNOME Shell. When processing icons from a remote search provider via D-Bus, the system fails to validate the icon's declared dimensions against the actual data buffer size. A malicious or compromised remote search provider could exploit this by providing oversized icon dimensions, leading to an out-of-bounds read. This can cause the GNOME Shell process to crash, disrupting the user's session, and potentially disclose sensitive information from adjacent memory.

CVSS Base Scores

version 3.1